CentOS 6.3(6.2에서는 라이브러리 버전을 타지 않는 건지 상관없는 것 같다.)에서는 capybara-webkit을 설치할 떄 qt "4.7" 라이브러리가 필요하다. 그러나 epel이나 rpmforge 같은 곳에서는 "4.6" 버전 밖에 없기 때문에 다른 서드파티 레포를 설치해야 한다. 


# rpm -i http://dl.atrpms.net/el6-x86_64/atrpms/stable/atrpms-repo-6-5.el6.x86_64.rpm

# yum install --enablerepo=atrpms-testing qt47-webkit-devel

# export QMAKE=/usr/bin/qmake-qt47


를 해주고 다시 설치를 진행하면 된다.


주의: 기존 qt 라이브러리는 꼭 지워주어야 한다. (어차피 yum으로 설치할 때 충돌 난다고 지우라고 하지만..)

댓글을 달아 주세요